ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
ClamWin and Moodle
jonwitts


Joined: 20 Dec 2005
Posts: 2
Reply with quote
I have a moodle installation running on a windows 2003 box with IIS PHP and MySQL installed. Moodle has the ability to use Clam AV to scan all file s uploaded to it, however this appears to only be tested with the *Unix version. I have installed ClamWin on my server and all seems fine, however I have changed the default installation path to C:\ClamWin and moved the .clamwin folder to the root of the C Drive as the spaces inherent in windows installs seemed to be providing problems for my moodle install to access clamwin. ClamWin appears to be running fine on the server with these new paths, but when I try to run ClamWIn from the command line I get this error,

C:\ClamWin\bin>clamscan.exe /C:\backup.bkf
LibClamAV Error: cl_loaddbdir(): Can't open directory /usr/local/share/clamav
ERROR: Unable to open file or directory

----------- SCAN SUMMARY -----------
Known viruses: 0
Engine version: 0.87.1
Scanned directories: 0
Scanned files: 0
Infected files: 0
Data scanned: 0.00 MB
Time: 0.000 sec (0 m 0 s)


Any ideas as to what the problem may be?? I am stumped. I think this is a ClamWin issue rather than a moodle issue, as all moodle does is point to the path to the command line scan utility.
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1748
Reply with quote
you need to specify some command line parameters to clamscan, the bare minimum is --database
for the list of parameters run "clamscan --help"
View user's profileSend private message
jonwitts


Joined: 20 Dec 2005
Posts: 2
Reply with quote
Thanks for your prompt reply, i have tried running clamwin again from the command line after looking at the help file and reading through the arguements, however I am still having problems. I am probably missing something really obvious here but I can not see the wood for the trees.

I have downloaded and tested clamwin with the zip files from eicar.org and clamwin detects and quarantines these files through windows explorer (right click, "Scan for Viruses with ClamWin"), however I am now getting this error when trying to run clamwin from the command line with the database argument ??

Please help.

C:\ClamWin\bin>clamscan --database=C:\.clamwin\db\main.vcd
ERROR: C:\.clamwin\db\main.vcd: Not supported database file type

----------- SCAN SUMMARY -----------
Known viruses: 0
Engine version: 0.87.1
Scanned directories: 0
Scanned files: 0
Infected files: 0
Data scanned: 0.00 MB
Time: 0.001 sec (0 m 0 s)
[/i]
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1748
Reply with quote
Quote:
C:\.clamwin\db\main.vcd

it should be: --database=C:\.clamwin\db
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1748
Reply with quote
you may also find this info the help-advanced operations
View user's profileSend private message
ClamWin and Moodle
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Reply to topic