ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
regexps in exclusion filters
rin!go


Joined: 25 May 2006
Posts: 34
Reply with quote
I'm trying to exclude files like:
file.7z.001
file.7z.002
....
I've created a regexp like this (I'm skipping the angle brackets since BB doesn't seem to like them):
Code:

.*\.7z\.0.*

but it doesn't work. Looks like it doesn't recognize dot in the name of the file when it's used like "\."
After many attempts I've managed to find a workaround that works:
Code:

.*[\.]7z[\.]0.*

Basically i'm checking for the class of characters consisting of a single dot character.
Any idea why the first one doesn't work?
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
there is a bug in clamwin that changes all \ to / in regexps. A patch is here:
http://files.clamwin.com/clamwin.zip

Please download it and overwrite the old clamwin.zip file in c:\program files\clamwin\lib\ folder.
View user's profileSend private message
rin!go


Joined: 25 May 2006
Posts: 34
Reply with quote
Yes, this seems to help! Thank you!
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
we will release a mainstream update after a while. There are some other changes, main being all files are now scanned in UNC naming format internally - this allows to open files that would otherwise fail due to invalid filename characters.

Would you like to beta test it?
View user's profileSend private message
rin!go


Joined: 25 May 2006
Posts: 34
Reply with quote
I don't have problems with this sort of files (or maybe I don't have such files). So I won't be able to tell if it's fixed or not. But of course I can run it just to see if anything else is broken. Sure, count me in.
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
well, we need general testing of this change too especially in the regex area as the filename format changed internally.

Please subscribe to the Beta Testers group here:
http://forums.clamwin.com/groupcp.php

After that you will have access to a private "Beta Test" forum in the "development" section
View user's profileSend private message
rin!go


Joined: 25 May 2006
Posts: 34
Reply with quote
Done. Still can't see "Beta Test" forum under "Development". Just Feature Requests and Translations.
(Sounds like beta-testing forum Smile)
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
try now, I approved your group membership
View user's profileSend private message
rin!go


Joined: 25 May 2006
Posts: 34
Reply with quote
Yes I can see that I'm approved but I still don't see "Beta Test" forum in the list of forums. Unless I missed some secret link.
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
I messed up with permissions, sorry. Should be ok now
View user's profileSend private message
rin!go


Joined: 25 May 2006
Posts: 34
Reply with quote
yes, works fine. I've subscribed to that single sticky message to be notified on beta releases.
View user's profileSend private message
regexps in exclusion filters
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Reply to topic