ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
AV Update
dbbota


Joined: 04 Oct 2011
Posts: 1
Location: Buford
Reply with quote
I am running ClamWin 0.97.2.

When choosing internet update preferences and select hourly frequency, the time should be NULL (grayed out) since the update would be at the top of the hour.

This is a suggestion and possible not a bug with the software.
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
The way it is, you have plenty of flexibility. I do my scans at the top of the hour and update at 5 minutes to the hour--so I will have the latest signatures. It's up to the user.

Regards,
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
Hello,

As a new user of ClamWin, I do think there is a bug with Hourly update selection. When I select Hourly update, indeed the timebox does not get grayed out. Besides this, the update doesn't work on Hourly basis. I've tested this on 2 computers and the ClamUpdateLog on both computers remains untouched. So my conclusion is the Hourly update isn't working. Of course I did check if the virus db was update, which it wasn't.

It's on Windows 2000 server, ClamWin version 0.97.3

Regards,
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
Make sure you have ticked the box to Allow Automatic Virus Database Updates under the Internet Updates tab.

Regards,
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
Thank you for your response. About your suggestion, this option is checked/active.

Regards,
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
Perhaps the problem is unique to your server. There don't seem to be any problems with hourly updates lately. Is everything else working okay--scanning, etc.?

Regards,
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
Everything works fine, it's just not updating hourly. I have this on two servers, both Windows 2000.
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
Clam AV is not on a strict schedule for updates. There are no regular hourly updates. Just set ClamWin to update hourly and it will check and update if updates are available. You will usually get from 2 to 10 updates per day.

Regards,
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
This I understand GuitarBob. But the thing is that updates are not applied on this schedule, I have to do this manual. Then the virus database is updated.

Regards
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
I just noticed that you said you were using ClamWin .97.2 (getting old/slow, I guess). You should always use the latest version, if at all possible. So update to .97.3 and see if that helps. If it doesn't, then maybe we can get a developer here. ClamWin isn't tested enough on anything prior to XP--the users need to get more involved in testing, and the same goes for network users.

Regards,
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
GuitarBob your not getting old, it's just that I posted in een old thread. The starter of this thread has/had the old version of ClamWin. I'm running the latest version; 0.97.3.
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
I see--well that proves I'm getting old! I'll mention this to the developers--let's see if they have any suggestions.

Regards,
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
I would like to provide the developers with some extra information, which is that the daily update tasks is also not working!

So my conslusion is that the automatic (scheduled) update is not working on Windows Server 2000.

Hope the developers can provide a solution for this.
View user's profileSend private message
rpa


Joined: 06 Jan 2012
Posts: 9
Reply with quote
At the moment it looks like automatic update is working. When looking into the option to update through the commandline, I found there was no freshclam.conf file on the server. Based on this thread; http://forums.clamwin.com/viewtopic.php?p=14611, I created a freshclam.conf file and did a succesfull manual update.

For test I created only the freshclam.conf file on the other server, and did not do a manual update through the GUI or commandline.

Both ClamUpdateLog.txt files now show a hourly update.
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4336
Location: USA
Reply with quote
I wonder how the config file got deleted. Anyway, I'm glad you found the problem. If I had suggested an uninstall/reinstall, that would have solved the problem initially, eh? I'll keep than in mind for the future. Maybe the ClamWin developers should add an "audit" capability to check whether/not important files are available.

Regards,
View user's profileSend private message
AV Update
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 2  

  
  
 Reply to topic