ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
Auto-updating not working correctly
euphorik


Joined: 04 Sep 2008
Posts: 4
Location: Georgia, USA
Reply with quote
First my setup: Clamwin 0.93.1 on Windows Vista Home Premium w/SP1

I have been having some difficulties with auto-updating not working correctly. Clamwin is currently set to download updates from the internet each day at 0130. However, when I check the log, no update has been downloaded since the last time I manually did the update.

I believe this behavior began when I upgraded to the latest version of clamwin. I have since uninstalled and reinstalled the application with no change to this behavior. I would say that manually updating works fine, but at this very moment I can't connect to any of the servers. However, I manually updated 5 days ago and it worked fine.

Scheduled virus scans are also not working correctly but I posted those details in the other forum (see http://forums.clamwin.com/viewtopic.php?t=1940 for details). Any help on this problem would be greatly appreciated. Thanks.

-Pete
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
can you please wait for the update time and then paste %tmp%\clamwin1.log contents here (don't open clamwin after the update as it will overwrite the log ?
View user's profileSend private message
Updating Trouble
meden199


Joined: 05 Sep 2008
Posts: 1
Reply with quote
I'm having the same problem.
With IE i cannot reacht: http://database.clamav.net/main.cvd
I do not use a proxy.

Any help???
This is the update log:



---
--------------------------------------
ClamAV update process started at Fri Sep 05 15:45:42 2008
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): WARNING: Can't get information about database.clamav.net: No IP address
WARNING: Can't read main.cvd header from database.clamav.net (IP: )
Trying again in 5 secs...
ClamAV update process started at Fri Sep 05 15:46:06 2008
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): WARNING: Can't get information about database.clamav.net: No IP address
WARNING: Can't read main.cvd header from database.clamav.net (IP: )
Trying again in 5 secs...
ClamAV update process started at Fri Sep 05 15:46:31 2008
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): ERROR: Can't get information about database.clamav.net: No IP address
WARNING: Can't read main.cvd header from database.clamav.net (IP: )
Giving up on database.clamav.net...
Update failed. Your network may be down or none of the mirrors listed in freshclam.conf is working. Check http://www.clamav.net/support/mirror-problem for possible reasons.
---
View user's profileSend private message
euphorik


Joined: 04 Sep 2008
Posts: 4
Location: Georgia, USA
Reply with quote
I'm pasting the entire contents of the file in here. Clearly, the second portion is for the scan, not the update. Additionally, there is no entry in ClamUpdateLog.txt. Thanks.

-Pete

System Locale: ('en_US', 'cp1252')
Default Encoding: cp1252
command line path:
Internet online: 1
Scheduler terminated
Exit Code: 0
Cleanup for process 00000d34
running task on: 05-09-08 02:30:00. Frequency is: Daily

Scanning: "C:\\"
clamscan.exe command line: "C:\Program Files\ClamWin\bin\clamscan.exe" --tempdir "c:\users\euphorik\appdata\local\temp" --keep-mbox --stdout --database="C:\ProgramData\.clamwin\db" --log="c:\users\euphorik\appdata\local\temp\tmp9lebsq" --no-phishing-sigs --no-phishing-scan-urls --no-mail --infected --max-files=500 --max-scansize=150M --max-recursion=5 --max-filesize=100M --move="C:\temp\clamwin-quarantine" --recursive --exclude="[^\]*\.dbx$" --exclude="[^\]*\.tbb$" --exclude="[^\]*\.pst$" --exclude="[^\]*\.dat$" --exclude="[^\]*\.log$" --exclude="[^\]*\.evt$" --exclude="[^\]*\.nsf$" --exclude="[^\]*\.ntf$" --exclude="[^\]*\.chm$" --kill "C:\\"
"C:\Program Files\ClamWin\bin\clamscan.exe" --tempdir "c:\users\euphorik\appdata\local\temp" --keep-mbox --stdout --database="C:\ProgramData\.clamwin\db" --log="c:\users\euphorik\appdata\local\temp\tmp9lebsq" --no-phishing-sigs --no-phishing-scan-urls --no-mail --infected --max-files=500 --max-scansize=150M --max-recursion=5 --max-filesize=100M --move="C:\temp\clamwin-quarantine" --recursive --exclude="[^\]*\.dbx$" --exclude="[^\]*\.tbb$" --exclude="[^\]*\.pst$" --exclude="[^\]*\.dat$" --exclude="[^\]*\.log$" --exclude="[^\]*\.evt$" --exclude="[^\]*\.nsf$" --exclude="[^\]*\.ntf$" --exclude="[^\]*\.chm$" --kill "C:\\" --memory
Scheduling task (<__main__>, 'C:\\', 'Scan C:\\ Daily', 1) for: Sat Sep 06 02:30:00 2008
Exit Code: -1073741819
Cleanup for process 00000d60
removing temp file clamav-26b1b99d15e70fb4c13eec34854565c4.00000d60.clamtmp
View user's profileSend private message
bytemind


Joined: 20 Oct 2008
Posts: 2
Reply with quote
I have the same problem - Did you get it resolved?

I run it on a windows 2003 server, and it never updates by itself, no user is logged on, could that be the problem? The problem is on 0.93 and 0.94
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
a user needs to be logged on with clamtray.exe running for clamwin scheduler to work
View user's profileSend private message
bytemind


Joined: 20 Oct 2008
Posts: 2
Reply with quote
Then... i am no longer a user of clamwin Sad
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
you can always use windows task scheduler and freshclam.exe
It has been discussed in this forum.
View user's profileSend private message
Recurring failure of the ClamWin updater
ClamWinPaul


Joined: 28 Jul 2008
Posts: 7
Reply with quote
When I first installed ClamWin a few versions ago, I could not get the program to collect updates -- even from the installer which prompts to get them during the installation. After much hair-pulling, I got it to work; but only from another workstation and using a batch file with the line:

\\SERVER\DRIVE_e\Clamwin\bin\freshclam --datadir=\\SERVER\DRIVE_e\Clamwin\db --config-file=\\SERVER\DRIVE_e\Clamwin\bin\freshclam.conf --log=\\SERVER\DRIVE_e\Clamwin\log\update.log

and with a specially modified FRESHCLAM.CONF provided to me by another user:

Checks 24
DNSDatabaseInfo current.cvd.clamav.net
DatabaseDirectory /var/clamav
DatabaseMirror db.local.clamav.net
DatabaseMirror database.clamav.net
DatabaseOwner clamav
# Foreground
# LogVerbose
MaxAttempts 6

Then I upgraded to v0.94 and the updating failed again. Now I've upgraded to 0.94.1 and still it refuses to update. I've even tried reverting to the original 2-line Freshclam.conf file with no success.

What happens is the updating window appears, reporting the time of the start of the update but nothing further happens regardless of how long I wait (10-15 minutes). The log file contains only that line as well. No clues as to the problem.
FWIW, these are W98SE machines on a home LAN.

What am I missing?

Paul
View user's profileSend private message
kit


Joined: 08 Jun 2009
Posts: 1
Reply with quote
Hi,

Im using XP home and for a long time I used to manually update the database no probs... then suddenly I started to get all the errors pasted on the forum here. Havent been able to update for months, uninstalled the prog, downloaded the latest version and I couldnt even download the database with the new installation from the clamwin site. Surely the developers must know this is happening to loads of people??? or have I missed the solution???

Best Kit
View user's profileSend private message
mazonemayu


Joined: 14 Jun 2009
Posts: 2
Reply with quote
hey,

since a day or 3 I'm getting the following error when I try to update my db:

Code:
ClamAV update process started at Sun Jun 14 09:52:37 2009
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): WARNING: Can't get information about database.clamav.net: No IP address
WARNING: Can't read main.cvd header from database.clamav.net (IP: )
Trying again in 5 secs...
ClamAV update process started at Sun Jun 14 09:53:06 2009
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): WARNING: Can't get information about database.clamav.net: No IP address
WARNING: Can't read main.cvd header from database.clamav.net (IP: )
Trying again in 5 secs...
ClamAV update process started at Sun Jun 14 09:53:35 2009
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): ERROR: Can't get information about database.clamav.net: No IP address
WARNING: Can't read main.cvd header from database.clamav.net (IP: )
Giving up on database.clamav.net...
Update failed. Your network may be down or none of the mirrors listed in c:\users\mike\appdata\local\temp\tmpkjdgk_ is working. Check http://www.clamav.net/support/mirror-problem for possible reasons.
LibClamAV Error: DNS Resolver: Can't query current.cvd.clamav.net
LibClamAV Error: DNS Resolver: Can't query current.cvd.clamav.net
LibClamAV Error: DNS Resolver: Can't query current.cvd.clamav.net

--------------------------------------
Completed
--------------------------------------


I read the FAQ & tried going to the clamav address in the message, but firefox just gives a blank page & says there's nothing there (so does IE btw)

thx
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4362
Location: USA
Reply with quote
You might uninstall ClamWin and then reinstall it. If you use another antivirus, run a scan with it before you reinstall. See if you get the signature databases (both of them) after the reinstall. Please get back here with results.

Regards,
View user's profileSend private message
mazonemayu


Joined: 14 Jun 2009
Posts: 2
Reply with quote
ok, so I reinstalled, it updated once & now it won't update (yet) again
god, I hate vista; it all started when got this new laptop with that shitty OS
I've allowed it in my firewwall settings & all...
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4362
Location: USA
Reply with quote
Make sure you have configured ClamWin for automatic updates in its Preferences - Internet Updates. If it's already configured, do some searching/FAQ reviewing for a similar problem on the ClamWin site.

Regards,
View user's profileSend private message
auto update and manually updates will not work
tgood


Joined: 25 Jun 2009
Posts: 1
Reply with quote
I have windows XP Professional 2002 Service Pack 2; my auto updates keeps giving me an error report. Any suggestions please be descriptive I am not a computer whiz.

Here is the error report below:

ClamAV update process started at Fri Jun 26 01:20:28 2009
main.cld is up to date (version: 51, sigs: 545035, f-level: 42, builder: sven)
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: Can't download daily.cvd from database.clamav.net
Trying again in 5 secs...
ClamAV update process started at Fri Jun 26 01:20:35 2009
main.cld is up to date (version: 51, sigs: 545035, f-level: 42, builder: sven)
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: Can't download daily.cvd from database.clamav.net
Trying again in 5 secs...
ClamAV update process started at Fri Jun 26 01:20:42 2009
main.cld is up to date (version: 51, sigs: 545035, f-level: 42, builder: sven)
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
WARNING: Can't get information about database.clamav.net: No IP address
WARNING: getpatch: Can't download daily-9420.cdiff from database.clamav.net
ERROR: Can't get information about database.clamav.net: No IP address
ERROR: Can't get information about database.clamav.net: No IP address
ERROR: Can't download daily.cvd from database.clamav.net
Giving up on database.clamav.net...
Update failed. Your network may be down or none of the mirrors listed in c:\docume~1\tasmin~1\locals~1\temp\tmphvzwve is working. Check http://www.clamav.net/support/mirror-problem for possible reasons.

--------------------------------------
Completed


Thanks
View user's profileSend private message
Auto-updating not working correctly
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 2  

  
  
 Reply to topic