ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
Clamwin scan hangs and wont complete (C drive only) - FIXED
uart


Joined: 02 Feb 2006
Posts: 7
Reply with quote
Hi, I am currently running Clamwin 0.87 and WinXP. Every time I do a manual scan on my "C:" drive it gets to somewhere in "documents and settings" and then just hangs there. I can leave it running for hours and it never ever gets past this point.

From memory I think that the last scanned files displayed are "C:\Documents and Settings\user\SendTo\....", it just cant seem to get past this point.

I have a few partitions on this hard drive and all the other partitions scan ok, it's only when scanning the system partition that Clamwin Hangs. Does anyone have any ideas on what could cause this? (C partition is only 8GB FAT32)

Just downloading version 0.88 now to test.


Last edited by uart on Fri Feb 03, 2006 2:51 pm; edited 3 times in total
View user's profileSend private message
uart


Joined: 02 Feb 2006
Posts: 7
Reply with quote
Yeah version 0.88 does exactly same thing. Here is the last thing displayed in the scanning Window before it hangs.

Quote:
C:\Documents and Settings\user\Start Menu\Programs\GNU Octave 2.1.50\GNU Octave 2.1.50 Quick Reference (PDF).lnk: OK
C:\Documents and Settings\user\Start Menu\Programs\GNU Octave 2.1.50\OctaveForge Quick Reference (HTML).url: OK
C:\Documents and Settings\user\Start Menu\Programs\GNU Octave 2.1.50\Epstk Manual (HTML).url: OK
C:\Documents and Settings\user\Start Menu\desktop.ini: OK
C:\Documents and Settings\user\SendTo\Compressed (zipped) Folder.ZFSendToTarget: Empty file
C:\Documents and Settings\user\SendTo\Desktop (create shortcut).DeskLink: Empty file
C:\Documents and Settings\user\SendTo\Mail Recipient.MAPIMail: Empty file
C:\Documents and Settings\user\SendTo\desktop.ini: OK
C:\Documents and Settings\user\SendTo\My Documents.mydocs: Empty file


Any ideas ?
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
how long did you wait? It can take quite a while to scan single file if it is large (mailboxes, etc)
View user's profileSend private message
uart


Joined: 02 Feb 2006
Posts: 7
Reply with quote
Quote:
how long did you wait?...

Thanks for the reply alch. Yes I wait hours and I'm certain it is completely hung as there is no disk activity. I do know what you mean about large files, I have observed that behaviour where it looks like progress has stopped but it's really just scannng a very long file. I've seen that on my other partitions were I have some large VOB files stored, but in this case I can clearly see that the hard drive is still working so I know it's not really hung-up.

My C drive is pretty clean, I've only got about 2.2Gig of used space on that partition! Additional my computer is very stable, it mostly runs for extended periods without any problems. I have also made surface scans etc of the hard-drive and ruled out any hardware problems.

I'm new here and I tried to do a bit of a search for similar issues but didn't find any exactly like this. Has anyone seen something like this before?
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
must be another cygwin issue. These issues will hopefully go away when we release native windows clamwin without cygwin compatibilty layer.
View user's profileSend private message
uart


Joined: 02 Feb 2006
Posts: 7
Reply with quote
Ok I've finally got it fixed. Very Happy

Since it seemed to be hanging while scanning system files and folders I was initially reluctant to play with it too much, like moving and deleting files or folders to try and pin-point which one was causing the problem. Anyway since there was no other way I logged in to Windows (xp-pro) as another admin user and starting knocking stuff out of my "documents and settings\user" folder until I could get it to complete a scan.

It turned out to be a zero length hidden/system file called "C:\Documents and Settings\user\recent.000". This file looked like something unimportant or temporary so I shift-deleted and now clamwin is working great. Very Happy

I hope this info can help someone else. Unfortunately I'm not 100% sure that the file was called exactly "recent.000", it might have been "recent documents.000", it was definitely called "recent*" and the extension was definitely ".000". Sorry I would have paid more attention if I had known that this was going to be the file that fixed it, but while I was mostly just moving other files and folders this particular file looked so unimportant that I just shift-deleted it, so now I have no record of it to confirm any further details. Embarassed
View user's profileSend private message
Clamwin scan hangs and wont complete (C drive only) - FIXED
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Reply to topic