ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
0.97.5 can't update virus db
Rolf


Joined: 02 Aug 2012
Posts: 5
Reply with quote
- search forum found no-one commenting on 0.97.5
- one earlier thread seemed almost, but not really there
- download site: database.clamav.net

- my system: MS WXP professional, SP3
- clamwin virus db dl functional in earlier versions

After downloading and installing 0.97.5 (full uninstall of previous version, off-line install of this version) downloading ("definitions more than five days old, would you like..." message, then dl) stalls for a very long time (gave up after 45 minutes).

When I give up, I click "Stop", which doesn't work, and I get a system error message, and I click "finish now". That gives the error message:

Unable to stop runner thread. Terminating.

I click OK, and it shuts down.

It's set to update virus db automatically, and seems to do so, but every time I click the desk top icon to check something in the settings, it says that my virus database is older than five days, and would I like to update?

Am I the only one with this problem? Any suggestions what to do? (I suppose I could wait until the next version of the program itself, the problem might go away then, but that seems a little unpractical.)

cheers/Rolf
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4376
Location: USA
Reply with quote
Hello Rolf. I don't recall hearing about any similar problems with ClamWin version .97.5. You might try an uninstall and then another install and see if it's okay then. Download the new version from the ClamWin website again just to be sure your install wasn't corrupted somehow. I have seen similar problems updating when the computer's clock is messed up--check that.

Get back to us if the problem continues, and we'll see what the developers say.

Regards.
View user's profileSend private message
Rolf


Joined: 02 Aug 2012
Posts: 5
Reply with quote
I did an extra uninstall/install just before I posted the problem (with a freshly downloaded copy). Same problem. Computer clock has no problem, as far as I can see.

cheers/Rolf
View user's profileSend private message
CyberSchwammerl


Joined: 03 Sep 2012
Posts: 2
Reply with quote
Since 6 days I have the same problem. Reinstallation doesn't change anything.
Before this point of time making updates was no problem. *?*
I use Win 7 64Bit.
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4376
Location: USA
Reply with quote
As reported elsewhere in the ClamWin forums, the Clam AV submission interface has been down for maintenance since last Tuesday--that is about 6 days. It seems to be available again, so they should start publishing sginatures in quantity again on Tuesday, Sept. 4.

Regards,
View user's profileSend private message
Rolf


Joined: 02 Aug 2012
Posts: 5
Reply with quote
GuitarBob wrote:
As reported elsewhere in the ClamWin forums, the Clam AV submission interface has been down for maintenance since last Tuesday--that is about 6 days. It seems to be available again, so they should start publishing sginatures in quantity again on Tuesday, Sept. 4.


Thanks! Sorry for being late in answering. I have installed clamwin on another machine, and thats seems to work allright.

cheers/Rolf
View user's profileSend private message
auto updating not occuring
cobrien


Joined: 18 Sep 2012
Posts: 4
Location: North Carolina
Reply with quote
I have installed clamwin on several servers (windows server 2008) and I have noticed that it is not auto-updating even though I have set for it to auto-update. Every time I log onto the servers, the popup comes up to tell me the definitions are out of date by xx days and would I like to run updates. I say yes, and they run and show in the report. Any ideas on why it might not be running at 4 a.m. daily as I have it set to do?
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4376
Location: USA
Reply with quote
If your computer clocks are oaky and you have configured the installed copies of ClamWin to enable automatic internet updates, with a daily frequency, at 4 AM, it should do it for you. As a practical matter, there are probably no current signatures at that time, but if it has been 24 hours since your last 4 AM update, there should be some signatures published the previous day that you will still need. You might try an uninstall and then a re-install to see if that is the problem. If you have just recently installed ClamWin, make sure that your firewall allows ClamWin updates .

Regards,
View user's profileSend private message
clamwin updates
cobrien


Joined: 18 Sep 2012
Posts: 4
Location: North Carolina
Reply with quote
1. Is running this on a server 2008 a problem?
2. What port on the firewall needs to be open for the updates?

thanks for any help you can provide. I will try uninstalling and reinstalling the program to see if that helps.

Celest
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4376
Location: USA
Reply with quote
As far as I know, ClamWin should work on a 2008 server. You might do a search on these forums for "2008 server" just to see. Ditto for ClamWin update/port, etc. I think it is port 80, but you might check you firewall logs to see if ClamWin is being denied access to the internet during automatic updates at around 4 am. Here is something I found on a quick search with Google (deals with Clam AV, but ClamWin is ported over from Clam AV): http://beginlinux.com/server/firewalls/creating-firewall-rules-with-freshclam.

Regards,
View user's profileSend private message
cobrien


Joined: 18 Sep 2012
Posts: 4
Location: North Carolina
Reply with quote
So on Wednesday the 26 of September, I thought uninstalling and reinstalling clamwin would solve the issue for me on clamwin not auto updating as scheduled. I uninstalled, reinstalled. Set a time for a few minutes away (at noon) for an update - it ran the update. Just to be sure I scheduled an upate for and hour later (at one) - It ran okay.

Here is a copy of the report for updates from clamwin:[/b]
lamAV update process started at Wed Sep 26 11:54:49 2012
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.97.5 Recommended version: 0.97.6
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
WARNING: getfile: daily-15115.cdiff not found on remote server (IP: 207.57.106.31)
WARNING: getpatch: Can't download daily-15115.cdiff from database.clamav.net
WARNING: getfile: daily-15115.cdiff not found on remote server (IP: 69.163.100.14)
WARNING: getpatch: Can't download daily-15115.cdiff from database.clamav.net
WARNING: getfile: daily-15115.cdiff not found on remote server (IP: 155.98.64.87)
WARNING: getpatch: Can't download daily-15115.cdiff from database.clamav.net
WARNING: Incremental update failed, trying to download daily.cvd
Downloading daily.cvd [100%]
daily.cvd updated (version: 15406, sigs: 268505, f-level: 63, builder: neo)
Downloading bytecode-188.cdiff [100%]
Downloading bytecode-189.cdiff [100%]
Downloading bytecode-190.cdiff [100%]
bytecode.cld updated (version: 190, sigs: 36, f-level: 63, builder: neo)
Database updated (1312928 signatures) from database.clamav.net (IP: 64.22.33.90)
--------------------------------------
ClamAV update process started at Wed Sep 26 12:00:00 2012
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.97.5 Recommended version: 0.97.6
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
daily.cvd is up to date (version: 15406, sigs: 268505, f-level: 63, builder: neo)
bytecode.cld is up to date (version: 190, sigs: 36, f-level: 63, builder: neo)
--------------------------------------
ClamAV update process started at Wed Sep 26 13:00:00 2012
main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
daily.cvd is up to date (version: 15406, sigs: 268505, f-level: 63, builder: neo)
bytecode.cld is up to date (version: 190, sigs: 36, f-level: 63, builder: neo)


I set the regular updates to occur at 11:00 nightly:

http://postimage.org/image/yrks1jv2t/
But as you can see from the report...it did not run wednesday night the 26th or last night on the 27th of september.

Suggestions?
View user's profileSend private message
GuitarBob


Joined: 09 Jul 2006
Posts: 4376
Location: USA
Reply with quote
Updating looks to be inconsistent. Sometimes an update isn't made because the mirrors aren't all synchronized. This is usually taken care of by the time the next update is scheduled. You might see if you can get automatic updates during normal working hours and see if they are stable. I suggest you also get the most recent version of ClamWin and see what happens. It shouldn't matter, but let's see.

Regards,
View user's profileSend private message
0.97.5 can't update virus db
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Reply to topic