ClamWin Free Antivirus Forum Index
ClamWin Free Antivirus
Support and Discussion Forums
Reply to topic
problem to update virus database via internet
iteranq


Joined: 17 May 2006
Posts: 3
Reply with quote
Hello, I'm using a proxy server to update the virus database via internet but I'm getting the following error:

ClamAV update process started at Wed May 17 09:08:53 2006
Connecting via 172.16.1.38
ERROR: Verification: Broken or not a CVD file
Trying again in 5 secs...
ClamAV update process started at Wed May 17 09:08:53 2006
Connecting via 172.16.1.38
ERROR: Verification: Broken or not a CVD file
Trying again in 5 secs...
ClamAV update process started at Wed May 17 09:08:53 2006
Connecting via 172.16.1.38
ERROR: Verification: Broken or not a CVD file
Giving up on database.clamav.net...
ERROR: Update failed. Your network may be down or none of the mirrors listed in freshclam.conf is working.

--------------------------------------
Completed
--------------------------------------


Would anyone tell me how to solve this issue?

Thanks,
Ivan Teran
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
most likely your proxy needs authentication. Did you specify username and password in clamwin proxy settings?
View user's profileSend private message
iteranq


Joined: 17 May 2006
Posts: 3
Reply with quote
[quote="alch"]most likely your proxy needs authentication. Did you specify username and password in clamwin proxy settings?[/quote]

Hola,

No, my proxy server does not need authentication, by now I discovered the problem, is that database.clamav.net does not get resolved here with the internet conection I use. Is there any other site where I can download the virus database?

Thanks,
Ivan Teran
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
db.local.clamav.net
db.xx.clamav.net (xx is a country code)
View user's profileSend private message
iteranq


Joined: 17 May 2006
Posts: 3
Reply with quote
[quote="alch"]db.local.clamav.net
db.xx.clamav.net (xx is a country code)[/quote]

Hello Alch,

I've changed the database server to the one You provided and it worked succesfully, thanks a lot!.

Regards,
Ivan Teran
View user's profileSend private message
doing the country code doesnt work for me
userclam


Joined: 23 May 2006
Posts: 4
Reply with quote
changing to countrycode does not work for me...if i'm not mistaken this error startedto happen after upgrading to latest version 0.88.2.3. internet update always work until this version. (not too sure about this tho') even if i use ip address it does not work - although you see the error message a bit faster...

i manually downloaded the defs to the proper folder and in the about diag-box is shows def date as may 23. can i assume that clamwin itself is fully functional?
following this, i then activate update via internet this error occurs: (192.168.1.13 is my proxy server, no auth.)

ClamAV update process started at Tue May 23 16:14:04 2006
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Connecting via 192.168.1.13
Reading CVD header (main.cvd): ERROR: Malformed CVD header detected.
ERROR: Can't read main.cvd header from db.my.clamav.net (IP: 192.168.1.13)
Trying again in 5 secs...
ClamAV update process started at Tue May 23 16:14:05 2006
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Connecting via 192.168.1.13
Reading CVD header (main.cvd): ERROR: Malformed CVD header detected.
ERROR: Can't read main.cvd header from db.my.clamav.net (IP: 192.168.1.13)
Trying again in 5 secs...
ClamAV update process started at Tue May 23 16:14:05 2006
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Connecting via 192.168.1.13
Reading CVD header (main.cvd): ERROR: Malformed CVD header detected.
ERROR: Can't read main.cvd header from db.my.clamav.net (IP: 192.168.1.13)
Giving up on db.my.clamav.net...
ERROR: Update failed. Your network may be down or none of the mirrors listed in freshclam.conf is working.

--------------------------------------
Completed
--------------------------------------

and i'm also using clamd on a linuxbox which update defs from database.clamav.net. clamd version is 0.88.2 and it also hit this error. from the ClamAV.update.log it shows that the "errors" started to occur intermittenly.

...
main.cvd is up to date (version: 38, sigs: 51206, f-level: 7, builder: tkojm)
ERROR: Verification: Broken or not a CVD file
Giving up on db.MY.clamav.net
ERROR: Update failed. Your network may be down or none of your mirrors listed in freshclam.conf is working.

i checked out the CVD file in /usr/local/share/clamav and it shows:
may 19 05:07 daily.cvd
apr 22 04:13 main.cvd

looks like it had failed to update daily.cvd since may 19th.

is it because of a corrupted CVD? mine or the source? or something else?
View user's profileSend private message
alch
Site Admin

Joined: 27 Nov 2005
Posts: 1751
Reply with quote
what type of a proxy server is it?
also try different db servers:
db.us.clamav.net, etc
View user's profileSend private message
userclam


Joined: 23 May 2006
Posts: 4
Reply with quote
squid proxy. thing is i dont think any thing changed on the proxy, and it works quite well. however, i noticed recently that clamwin auto defs update occassionally ballooned "update failure error", but if i do 'Download virus Database update' it completed successfully.

well, the error is stating Malformed CVD.. Can't read main.cvd header from... i don't think it is connectivity issue. Internet access is ok here.

db.us.clamav.net:
ClamAV update process started at Wed May 24 08:32:05 2006
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Connecting via 192.168.1.13
Reading CVD header (main.cvd): ERROR: Malformed CVD header detected.
ERROR: Can't read main.cvd header from db.us.clamav.net (IP: 192.168.1.13)
Trying again in 5 secs...
ClamAV update process started at Wed May 24 08:32:05 2006
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Connecting via 192.168.1.13
Reading CVD header (main.cvd): ERROR: Malformed CVD header detected.
ERROR: Can't read main.cvd header from db.us.clamav.net (IP: 192.168.1.13)
Trying again in 5 secs...
ClamAV update process started at Wed May 24 08:32:06 2006
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Connecting via 192.168.1.13
Reading CVD header (main.cvd): ERROR: Malformed CVD header detected.
ERROR: Can't read main.cvd header from db.us.clamav.net (IP: 192.168.1.13)
Giving up on db.us.clamav.net...
ERROR: Update failed. Your network may be down or none of the mirrors listed in freshclam.conf is working.

--------------------------------------
Completed
--------------------------------------

HOWEVER, looking into the Update Log:
-------------------------------------- NOVEMBER 05----
ClamAV update process started at Sat Nov 5 11:25:11 2005
ERROR: Can't get information about database.clamav.net: No IP address
Trying again in 5 secs...
ClamAV update process started at Sat Nov 5 11:25:18 2005
ERROR: Can't query current.cvd.clamav.net
WARNING: Invalid DNS reply. Falling back to HTTP mode.
ERROR: Can't get information about database.clamav.net: No IP address
Trying again in 5 secs...
ClamAV update process started at Sat Nov 5 11:25:24 2005
ERROR: Can't query current.cvd.clamav.net
WARNING: Invalid DNS reply. Falling back to HTTP mode.
ERROR: Can't get information about database.clamav.net: No IP address
Giving up on database.clamav.net...
ERROR: Update failed. Your network may be down or none of the mirrors listed in freshclam.conf is working.
ERROR: Update failed. Your network may be down or none of the mirrors listed in freshclam.conf is working.
--------------------------------------

this looks similar to the current problem.

ClamAV update process started at Sat Nov 5 11:25:46 2005
ERROR: Can't query current.cvd.clamav.net
WARNING: Invalid DNS reply. Falling back to HTTP mode.
main.cvd updated (version: 34, sigs: 39625, f-level: 5, builder: tkojm)
daily.cvd updated (version: 1162, sigs: 1306, f-level: 6, builder: tomek)
Database updated (40931 signatures) from database.clamav.net
--------------------------------------

the very next attempt was successful. the rest of the log until today shows mostly successful update with occassional failures. now the errors are clustered together without a single success.
View user's profileSend private message
HTTP Error 403: Forbidden
userclam


Joined: 23 May 2006
Posts: 4
Reply with quote
(virus defs internet update not resolved)

when clamwin auto check for latest version this error ballooned:

Unable to get online version. Most likely it's a temporary connectivity error and you don't have to do anything. If you see this error often then allow clamwin.exe in your firewall and check proxy settings. (HTTP Error 403: Forbidden)

i've checked my desktop firewall - tiny firewall 2 - and rules are set to allow clamwin.exe and freshclam.exe to anywhere. to confirm these rules are effective, a firewall feature allow a diagbox to open/pop when particular rules are triggered - they did pop each time:

TCP Connection to 192.168.1.13:80 was permitted by rule 'ClamAV Antivirus'
25/May/2006 09:54:00 ClamAV Antivirus permitted; Out TCP; localhost:80->192.168.1.13:80; Owner: D:\PROGRAM FILES\CLAMWIN3\BIN\FRESHCLAM.EXE
25/May/2006 09:54:00 ClamAV Antivirus permitted; Out TCP; localhost:80->192.168.1.13:80; Owner: D:\PROGRAM FILES\CLAMWIN3\BIN\FRESHCLAM.EXE
25/May/2006 09:54:00 ClamAV Antivirus permitted; Out TCP; localhost:80->192.168.1.13:80; Owner: D:\PROGRAM FILES\CLAMWIN3\BIN\FRESHCLAM.EXE

apparently freshclam.exe made 3 attempts before giving up.

i've also tried a cygwin compile (http://www.hostingu.nl/index.cfm?content=clamav) and ran freshclam from commandline - same kind of errors.

i've tried other mirrors randomly with the same errors.

hope this help to resolve my problem.
View user's profileSend private message
i humbly apologize!
userclam


Joined: 23 May 2006
Posts: 4
Reply with quote
i most humbly apologize! it was my own doing that prevent clamwin from reaching the internet.

my proxy *did* changed! it was configured to allow only "certain clients". now that is disabled updates are successful again.
Embarassed
i suppose i "mixed" up the analysis of the logs --because there *were* similar failures going back to november 05.

sorry sir!
View user's profileSend private message
problem to update virus database via internet
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Reply to topic